Building Qt for Linux/ru

From Qt Wiki
Revision as of 14:06, 14 January 2015 by Maintenance script (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Эта страница на: Русском English Português Spanish

Сборка Qt в Linux

Qt очень большой фреймворк, он включает множество модулей, конфигурационных параметров и дополнительный возможностей.
Это может быть проблемой, когда вы собираете его из исходного кода. Как найти и установить все требуемые зависимости? Как включить неизведанные возможности в билд?

Ниже приводиться полный список пакетов зависмостей для все версий Qt между 4.5 и мастер-веткой по состоянию на декабрь 2010. В настоящий момент имена пакетов описаны только для Ubuntu, но для большинства дистрибутивов они будут совпадать.

Колонка “Модуль” отображает самый низкоуровневый модуль, который использует данную функцию (то есть, если QtCore использует эту функцию, то QtGui не будет перечислен). Нескольно модулей указываются только если они не являются взаимозависимыми.

1 Несмотря на то что это поддерживается, я не смог собрать с этой опцией в Qt 4.5.

2 Необходимо добавить ‑DMESA_EGL_NO_X11_HEADERS в “configure” для сборки Qt/Embedded. Возможно это можно сделать с помощью .qmake.cache?

3 Необходимо добавить “$(pkg‑config gstreamer‑interfaces‑0.10 gstreamer‑video‑0.10 gstreamer‑base‑0.10 ‑‑cflags‑only‑I)” в “configure”.

4 Это также требует libGLES_CM.so.

5 Использование libiodbc2 вместо unixodbc поддерживается начиная с Qt 4.6.

6 Необходимо выполниить команду “ln ‑s libfbclient.so /usr/lib/libgds.so” после установки пакета.

Categories: