Nokia Smart Installer for Symbian

From Qt Wiki
Revision as of 12:26, 17 April 2015 by AutoSpider (talk | contribs) (Remove non-functioning "toc" command)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
IMPORTANT: The content of this page is outdated. Reason: The Symbian platform is no longer supported.
If you have checked or updated this page and found the content to be suitable, please remove this notice.
EnglishБългарскиSpanish

Nokia Smart Installer for Symbian

Smart Installer

Nokia Smart Installer for Symbian (also known just as Smart Installer) is a deployment solution that ensures that installed 3rd party applications have always access to the required versions of their dependent libraries on the phone.

Please note that Nokia Ovi Store requires usage of the Nokia Smart Installer for all Qt applications for Symbian!

Download

Nokia Smart Installer is included in the Nokia Qt SDK.

Packages distributed by Smart Installer

As of May 2011 the following libraries are hosted on Nokia's Smart Installer server and can be installed to the device prior installation of an Symbian application using the Smart Installer solution:

  • Stdcpp
  • OpenC_SSL
  • PIPS
  • Sqlite
  • Qt
  • QtWebkit
  • QtMobility
  • ClientPlatform(S60)
  • Ovi Notifications Support Package(S60)
  • Ovi Notifications Support Package Launcher(S60)
  • Ovi Notifications Support Package Launcher(S3)
  • SSO (S3)
  • SSO Ui(S3)
  • SSO Username widget(S3)
  • Ovi-shared widget(S3)

Devices

Supported Devices

Nokia Smart Installer is designed to work with Symbian S60 3rd Edition Feature Pack 1 and newer devices (including Symbian^1 and Symbian^3). Please note that the Smart Installer will check with the server if the device is known and supported, and this verification will currently fail for non-Nokia devices!

Devices not supported by Smart Installer

Unfortunately due to technical limitations Nokia Smart Installer is not compatible to the following device despite that they are with appropriate Symbian version:

  • Nokia 6650 AT&T variant (PIPS cannot be upgraded.)
  • Nokia N96 (Not supported by Qt)

Video Tutorial

Developing with Qt: Nokia Smart Installer

https://www.youtube.com/watch?v=PNwNlPoObvI

References

Nokia Developer: Nokia Smart Installer for Symbian