Difference between revisions of "Qt-5-on-Nokia-N9"

From Qt Wiki
Jump to: navigation, search
 
Line 1: Line 1:
=Qt 5 on the Nokia N9=
+
h1. Qt 5 on the Nokia N9
  
 
While there is no official support for Qt5 on Nokia N9 and N950 devices, community-provided snapshots are available through the QtWebkit project. These snapshots are based on weekly hashes used by QtWebkit build bots.
 
While there is no official support for Qt5 on Nokia N9 and N950 devices, community-provided snapshots are available through the QtWebkit project. These snapshots are based on weekly hashes used by QtWebkit build bots.
  
==Installation==
+
== Installation ==
  
 
On scratchbox:
 
On scratchbox:
  
* Add “deb http://snowshoe.cc/apt/ unstable main xcb” to /etc/apt/sources.list
+
* Add "deb http://snowshoe.cc/apt/ unstable main xcb" to /etc/apt/sources.list
  
 
On the device:
 
On the device:
  
* Install the “Qt5 repository package”: http://snowshoe.openbossa.org/apt/snowshoe-repositories.deb. It will add the Qt5 repository to the sources list and add the required <span class="caps">GPG</span> key.
+
* Install the &quot;Qt5 repository package&amp;quot;: http://snowshoe.openbossa.org/apt/snowshoe-repositories.deb. It will add the Qt5 repository to the sources list and add the required GPG key.
* Using a package manager (e. g. [http://store.ovi.com/content/220215 MeeCatalog] ''[store.ovi.com]''), install the qt5-all meta package. It will install all qt5 available packages. But if you get “Couldn’t find package qt5-all”, you should do “apt-get update” and then try installing it again.
+
* Using a package manager (e. g. &quot;MeeCatalog&amp;quot;:http://store.ovi.com/content/220215), install the qt5-all meta package. It will install all qt5 available packages. But if you get &quot;Couldn't find package qt5-all&amp;quot;, you should do &quot;apt-get update&amp;quot; and then try installing it again.
* Along with the Qt5 packages the repository will provide the missing xcb-util using the scratchbox’ packages.
+
* Along with the Qt5 packages the repository will provide the missing xcb-util using the scratchbox' packages.
  
To install manually, without the repository package, run the steps below as root. To become root use “devel-su” in the n9 terminal.
+
To install manually, without the repository package, run the steps below as root. To become root use &quot;devel-su&amp;quot; in the n9 terminal.
  
 
* Add the same repository line for scratchbox to /etc/apt/sources.d/qt5.list
 
* Add the same repository line for scratchbox to /etc/apt/sources.d/qt5.list
* Add the <span class="caps">GPG</span> key running “wget -O – http://snowshoe.cc/apt/conf/Qt5N9.gpg.key | apt-key add – “
+
* Add the GPG key running &quot;wget <s>O</s> http://snowshoe.cc/apt/conf/Qt5N9.gpg.key | apt-key add - &quot;
* Update the package list with “apt-get update”
+
* Update the package list with &quot;apt-get update&amp;quot;
* Install with “apt-get install “qt5-*” “
+
* Install with &quot;apt-get install &quot;qt5-'''&quot; &quot;
 
+
<br />h2. Usage  
==Usage==
+
<br />All modules are installed to /opt/qt5. To use qmlscene, qmake and other executables, just point PATH to /opt/qt5/bin.
 
+
<br />h2. Currently packaged modules  
All modules are installed to /opt/qt5. To use qmlscene, qmake and other executables, just point <span class="caps">PATH</span> to /opt/qt5/bin.
+
<br />''' QtBase: '''qt5-base'''
 
 
==Currently packaged modules==
 
 
 
* QtBase: '''qt5-base'''
 
 
* QtJSBackend: '''qt5-jsbackend'''
 
* QtJSBackend: '''qt5-jsbackend'''
 
* QtXMLPatterns: '''qt5-xmlpatterns'''
 
* QtXMLPatterns: '''qt5-xmlpatterns'''
Line 40: Line 36:
 
* Snowshoe mobile: '''snowshoe-mobile'''
 
* Snowshoe mobile: '''snowshoe-mobile'''
  
==More information==
+
== More information ==
 
 
Most instructions here are based on Snowshoe’s installation guide (link [http://snowshoe.openbossa.org/?installonn9 here] ''[snowshoe.openbossa.org]''). If you find any misleading step here, please check there and feel free to update with more accurate data here.
 

Revision as of 09:01, 24 February 2015

h1. Qt 5 on the Nokia N9

While there is no official support for Qt5 on Nokia N9 and N950 devices, community-provided snapshots are available through the QtWebkit project. These snapshots are based on weekly hashes used by QtWebkit build bots.

Installation

On scratchbox:

On the device:

  • Install the "Qt5 repository package&quot;: http://snowshoe.openbossa.org/apt/snowshoe-repositories.deb. It will add the Qt5 repository to the sources list and add the required GPG key.
  • Using a package manager (e. g. "MeeCatalog&quot;:http://store.ovi.com/content/220215), install the qt5-all meta package. It will install all qt5 available packages. But if you get "Couldn't find package qt5-all&quot;, you should do "apt-get update&quot; and then try installing it again.
  • Along with the Qt5 packages the repository will provide the missing xcb-util using the scratchbox' packages.

To install manually, without the repository package, run the steps below as root. To become root use "devel-su&quot; in the n9 terminal.

  • Add the same repository line for scratchbox to /etc/apt/sources.d/qt5.list
  • Add the GPG key running "wget O http://snowshoe.cc/apt/conf/Qt5N9.gpg.key | apt-key add - "
  • Update the package list with "apt-get update&quot;
  • Install with "apt-get install "qt5-" "


h2. Usage
All modules are installed to /opt/qt5. To use qmlscene, qmake and other executables, just point PATH to /opt/qt5/bin.
h2. Currently packaged modules
QtBase: qt5-base

  • QtJSBackend: qt5-jsbackend
  • QtXMLPatterns: qt5-xmlpatterns
  • QtDeclarative: qt5-declarative
  • QtScript: qt5-script
  • Qt3D: qt5-q3d
  • QtLocation: qt5-location
  • QtSensors: qt5-sensors
  • QtWebKit: webkit-snapshot
  • QtComponents for QtQuick2: qt-components2
  • Snowshoe mobile: snowshoe-mobile

More information