QtCS2015 QtOnQNX

From Qt Wiki
Revision as of 15:17, 11 June 2015 by NetZwerg (talk | contribs) (Added Category)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Qt on QNX

SDP 6.5

  • clarify: which Qt version supports which SDP (put it on the Wiki)
  • drop SDP 6.5 for Qt 5.6 (because of improved C++11 support etc.)

new QPA plugin

  • new features: foreign windows, new properties, transparency...
  • full support for foreign windows
  • Qt app can act as a window manager
  • release new screen features etc. on top of 6.6 (~ later this year?)
  • new feature in screen: window manager events (e.g. resize child window)
  • plugin will be upstreamed at some point
  • current and new plugin can live concurrently for a while
  • also comes with new event dispatcher (not using select() anymore, now: msg_recv)
  • problem with grabbing window contents: can be implemented in QPA plugin, works with native screen
  • virtual keyboard: part of QNX Car, but not normal SDP. There is a Qt virtual keyboard as well, running in the same process. Task: use virtual keyboard.

CI on QNX

  • 6.6 is on CI (only building), 6.5 is just nightly build
  • we need manual QA (maybe from QNX), because there is nothing automated
  • need to run auto tests on QNX as well, at least before the release

QtCreator QNX support

  • Creator 3.5: need to verify QNX is still working, now that BlackBerry is gone
  • building BSPs from QtCreator: Momentics is the main tool for that

BB10 in Qt

  • hard to remove because it is intertwined with QNX code
  • still working, leave it in for now, it might break or not
  • still supported according to documentation: we need to remove claiming that it is supported
  • sensors, bluetooth, NFC: this is all dead code, if nobody looks at it, it will be removed eventually
  • if somebody from QNX wants to use old BB / QNX code, they should step up

C++11

  • SDP 6.6 gcc version: 4.7
  • there are 2 C++ stdlib implementations on QNX: GNU C++ / Dinkumware
  • Dinkumware is a problem wrt. C++11
  • Thiago: QNX might want to switch to libstdc++, if problem is only the license
  • need to check qtbase test_auto_other_compiler to check for Dinkumware's C++11 support

Chromium on QNX

  • needed for QtWebEngine on QNX
  • also needs C++11
  • current Web technology is based on Webkit
  • QtWebkit at least works on QNX