Difference between revisions of "Qt 5.12 Tools and Versions"

From Qt Wiki
Jump to: navigation, search
Line 306: Line 306:
 
|
 
|
 
=== Ubuntu 16.04 x86_64 ===
 
=== Ubuntu 16.04 x86_64 ===
|
 
=== Ubuntu 18.04 x86_64 ===
 
 
|
 
|
 
=== openSUSE 42.3 x86_64 ===
 
=== openSUSE 42.3 x86_64 ===
Line 313: Line 311:
  
 
|'''Android NDK'''
 
|'''Android NDK'''
|r16b
 
 
|r16b
 
|r16b
 
|r16b
 
|r16b
Line 320: Line 317:
  
 
|'''Android SDK API level'''
 
|'''Android SDK API level'''
|android-21
 
 
|android-21
 
|android-21
 
|android-21
 
|android-21
Line 327: Line 323:
  
 
|'''Android SDK Build Tools'''
 
|'''Android SDK Build Tools'''
|25.0.2
 
 
|25.0.2
 
|25.0.2
 
|25.0.2
 
|25.0.2
Line 334: Line 329:
  
 
|'''Android SDK tools'''
 
|'''Android SDK tools'''
|r25.2.5
 
 
|r25.2.5
 
|r25.2.5
 
|r25.2.5
 
|r25.2.5
Line 341: Line 335:
  
 
|'''CMake'''
 
|'''CMake'''
|3.6.2
 
 
|3.6.2
 
|3.6.2
 
|3.6.2
 
|3.6.2
Line 348: Line 341:
  
 
|'''FBX SDK'''
 
|'''FBX SDK'''
|2016.1.2
 
 
|2016.1.2
 
|2016.1.2
 
|2016.1.2
 
|2016.1.2
Line 357: Line 349:
 
| -
 
| -
 
| -
 
| -
|8.2.0
 
 
| -
 
| -
 
|-
 
|-
  
 
|'''ICC'''
 
|'''ICC'''
| -
 
 
| -
 
| -
 
| -
 
| -
Line 370: Line 360:
 
|'''ICU'''
 
|'''ICU'''
 
|56.1
 
|56.1
| -
 
 
| -
 
| -
 
| -
 
| -
Line 377: Line 366:
 
|'''INTEGRITY'''
 
|'''INTEGRITY'''
 
|11.4.4
 
|11.4.4
| -
 
 
| -
 
| -
 
| -
 
| -
Line 383: Line 371:
  
 
|'''MQTT_BROKER'''
 
|'''MQTT_BROKER'''
|20bad2475c27a6e1d24a56d90a9fceb40963261e
 
 
|20bad2475c27a6e1d24a56d90a9fceb40963261e
 
|20bad2475c27a6e1d24a56d90a9fceb40963261e
 
|20bad2475c27a6e1d24a56d90a9fceb40963261e
 
|20bad2475c27a6e1d24a56d90a9fceb40963261e
Line 392: Line 379:
 
|1.0.2o
 
|1.0.2o
 
| -
 
| -
|1.0.2o
 
 
| -
 
| -
 
|-
 
|-
  
 
|'''QNX SDP'''
 
|'''QNX SDP'''
|7.0.0
 
 
|7.0.0
 
|7.0.0
 
|7.0.0
 
|7.0.0
Line 406: Line 391:
 
| -
 
| -
 
| -
 
| -
|2.3.4
 
 
| -
 
| -
 
|-
 
|-
Line 413: Line 397:
 
| -
 
| -
 
| -
 
| -
|2.3.4
 
 
| -
 
| -
 
|-
 
|-
  
 
|'''libClang'''
 
|'''libClang'''
|6.0
 
 
|6.0
 
|6.0
 
|6.0
 
|6.0
Line 426: Line 408:
 
|'''p7zip'''
 
|'''p7zip'''
 
|7-11
 
|7-11
| -
 
 
| -
 
| -
 
| -
 
| -

Revision as of 07:18, 28 September 2018

Note that these configurations do not represent our supported platforms. Those can be found

Current dev is targeting 5.12.0. The tools and operating systems with which it is tested are under constant development. Live information can be viewed at our public Coin page

Major SW updates compared to 5.11.x

Software configurations for Qt 5.12.0

Tools & Versions

windows 10 x86_64

windows 7 x86

7-Zip 16.04 16.04
Android NDK - r16b
Android OpenSSL - 1.0.2o
Android SDK Api Level - android-21
Android SDK Build Tools - 23.0.3
Android SDK tools - r24.4.1
CMake 3.6.2 3.6.2
Conan 0.24.0 0.24.0
Dependency Walker 2.2.6000 2.2.6000
DirectX SDK 9.29.1962 (Jun 10) 9.29.1962 (Jun 10)
FBX SDK 2016.1.2 -
Git 2.13.0 2.13.0
ICU 53_1 53_1
Java SE 8u144 x64 8u144 i586
Jom 1.1.2 1.1.2
Mesa llvmpipe 11_2_2 11_2_2
MinGW 7.3.0 x86_64-7.3.0-release-posix-seh-rt_v5-rev0 7.3.0 i686-7.3.0-release-posix-dwarf-rt_v5-rev0
Msys - 1.0.11
MySQL 5.6.11 5.6.11
Ninja 1.6.0 1.6.0
Notepad++ 7.3 7.3
OpenSSL 1_0_2o 1_0_2o
PostgreSQL 9.1.9-1 9.1.9-1
Python-32 2.7.13 2.7.13
Python-64 2.7.13 -
Python3-32 3.6.1 3.6.1
Python3-64 3.6.1 -
QNX SDP 7.0.0 -
Ruby 2.4.2-2 2.4.2-2
VirtualBox 5.2.4 -
Visual Studio 2015 update3 (KB3165756) -
Visual Studio 2015 Version 14.0.25421.3 Update 3 -
Visual Studio 2017 Version 15.1 (26403.7) -
Visual Studio 2017 Build Tools Version 15.1 (26403.7) -
Vulkan SDK 1.0.51.0 -
libClang 6.0 -
libusb libusb-1.0.21 -
strawberry 5.26.0.1 5.26.0.1

macos 10.12 x86_64

macos 10.13 x86_64

Android NDK - r16b
Android SDK API level - android-21
Android SDK Build Tools - 25.0.2
Android SDK tools - r25.2.5
CMake 3.11.3 3.11.3
Command Line Tools 8.3.2 9.4.1
FBX SDK 2016.1.2 2016.1.2
JDK Version 8 update 102 8 update 102
MySQL 5.7.15 5.7.15
OpenSSL 1.0.2o 1.0.2o
PostgreSQL 9.6.0 9.6.0
QNX SDP - 7.0.0
XZ 5.0.7 5.0.7
Xcode 8.3.3 9.4.1
libClang 6.0 6.0
python2 2.7.14 2.7.14
python3 3.6.1 3.6.1

RHEL 7.4 x86_64

Ubuntu 16.04 x86_64

openSUSE 42.3 x86_64

Android NDK r16b r16b -
Android SDK API level android-21 android-21 -
Android SDK Build Tools 25.0.2 25.0.2 -
Android SDK tools r25.2.5 r25.2.5 -
CMake 3.6.2 3.6.2 3.6.2
FBX SDK 2016.1.2 2016.1.2 -
GCC - - -
ICC - - 18.0.1 20171018
ICU 56.1 - -
INTEGRITY 11.4.4 - -
MQTT_BROKER 20bad2475c27a6e1d24a56d90a9fceb40963261e 20bad2475c27a6e1d24a56d90a9fceb40963261e 20bad2475c27a6e1d24a56d90a9fceb40963261e
OpenSSL for Android 1.0.2o - -
QNX SDP 7.0.0 7.0.0 -
Yocto ARM64 toolchain - - -
Yocto ARMv7 toolchain - - -
libClang 6.0 6.0 6.0
p7zip 7-11 - -