Difference between revisions of "Qt 5.6.0 Known Issues"

From Qt Wiki
Jump to: navigation, search
(Added details about DirectFB failure to build)
Line 10: Line 10:
 
* Qt WebEngine fails to build for Red Hat / CentOS 6.6 [https://bugreports.qt.io/browse/QTBUG-48298 QTBUG-48298]
 
* Qt WebEngine fails to build for Red Hat / CentOS 6.6 [https://bugreports.qt.io/browse/QTBUG-48298 QTBUG-48298]
 
** Workaround: See patch in the bug report
 
** Workaround: See patch in the bug report
* Qt support for DirectFB fails to build with some older versions of DirectFB. We have been unable to tell which is the first version known to compile, since DirectFB.org is unreachable.
+
* Qt support for DirectFB fails to build with some older versions of DirectFB. We have been unable to tell which is the first version known to compile, since DirectFB.org is unreachable. Workarounds:
** Workarounds:
+
*# configure Qt with the -no-directfb option; or
**# configure Qt with the -no-directfb option; or
+
*# remove your DirectFB development files; or
**# remove your DirectFB development files; or
+
*# upgrade to a more recent version
**# upgrade to a more recent version
+
* kded and kiod are known to deadlock with QtDBus. Linux distributions shipping KDE Frameworks 5 applications are advised to backport the patch from https://codereview.qt-project.org/151459. See also [https://bugreports.qt.io/browse/QTBUG-51676 QTBUG-51676]
  
 
== Windows ==
 
== Windows ==

Revision as of 06:24, 16 March 2016

Known Issues - Qt 5.6.0

All platforms

Linux

  • Qt WebEngine fails to build for Red Hat / CentOS 6.6 QTBUG-48298
    • Workaround: See patch in the bug report
  • Qt support for DirectFB fails to build with some older versions of DirectFB. We have been unable to tell which is the first version known to compile, since DirectFB.org is unreachable. Workarounds:
    1. configure Qt with the -no-directfb option; or
    2. remove your DirectFB development files; or
    3. upgrade to a more recent version
  • kded and kiod are known to deadlock with QtDBus. Linux distributions shipping KDE Frameworks 5 applications are advised to backport the patch from https://codereview.qt-project.org/151459. See also QTBUG-51676

Windows

  • Qt WebEngine cannot be compiled for Windows XP (QTBUG-49900)

Mac

iOS

  • Application crashes if project contains in any of its subfolders a QML component with QtNfc import statement (QTBUG-51860)

Qt Labs Controls

  • The Gallery example uses Qt Quick Layouts, which is shipped as part of the Qt Quick Controls component. However, in the installer the Qt Quick Controls component is not marked as a dependency to the Qt Labs Controls component. Both components need to be selected in order to be able to run the Qt Labs Controls Gallery example.

Qt 3D Technology Preview

Fails to compile on older versions of gcc, e.g. gcc-4.4.7 shipped with CentOS 6. There is a potential fix for this at https://codereview.qt-project.org/#/c/152345/ which will appear in Qt 5.6.1.