Difference between revisions of "Qt for Python/GettingStarted"

From Qt Wiki
Jump to: navigation, search
(Created page with "== Considerations before starting == bla")
 
(Considerations before starting)
Line 1: Line 1:
 
== Considerations before starting ==
 
== Considerations before starting ==
  
bla
+
PySide2 supports Python 2 (recommended: 2.7 onwards) and Python 3 (recommended: 3.5 onwards).
 +
 
 +
When planning development, it is helpful to have debug binaries and/or symbols for Python available. On Windows, this is done choosing ''Customized Installation'' when installing python and ticking the respective check boxes. On Linux, debug packages can be installed in addition.
 +
 
 +
For development, it is also recommended to use a [http://docs.python-guide.org/en/latest/dev/virtualenvs/ Virtual Environment] for testing to be able to always start from a clean base and avoid issues with write permissions in installations.

Revision as of 11:59, 29 August 2016

Considerations before starting

PySide2 supports Python 2 (recommended: 2.7 onwards) and Python 3 (recommended: 3.5 onwards).

When planning development, it is helpful to have debug binaries and/or symbols for Python available. On Windows, this is done choosing Customized Installation when installing python and ticking the respective check boxes. On Linux, debug packages can be installed in addition.

For development, it is also recommended to use a Virtual Environment for testing to be able to always start from a clean base and avoid issues with write permissions in installations.