Difference between revisions of "Qt for Python Development Notes"

From Qt Wiki
Jump to: navigation, search
(2020)
Line 8: Line 8:
 
* Python 3.8 fix to old branches is required for distributions using 5.12 LTS like Conda.
 
* Python 3.8 fix to old branches is required for distributions using 5.12 LTS like Conda.
 
* Working on Q_ENUM support.
 
* Working on Q_ENUM support.
 +
* Viewer for [https://bugreports.qt.io/browse/PYSIDE-803 PYSIDE-803] is ready to try.
  
 
==== 9. January 2020 ====
 
==== 9. January 2020 ====

Revision as of 15:00, 16 January 2020

2020

16. January 2020

  • CI/macOS problems are being worked.
  • qApp fix waiting to be merge.
  • first attempts to tackle PYSIDE-803
  • Python 3.8 fix to old branches is required for distributions using 5.12 LTS like Conda.
  • Working on Q_ENUM support.
  • Viewer for PYSIDE-803 is ready to try.

9. January 2020

  • PYSIDE-803 needs to be tackled soon, it's critical, and we cannot carry that into Qt6.
  • Python 3.8.1 on Windows has some issues while building.
  • qApp macro changes discussion.
  • documentation updates are still pending.
  • with the release of 5.14 we have been fixing many details from uic's Python support.
  • designer's RUNPATH needed to be patched, waiting for approval,
  • A modular way of packing wheels is being studied.
  • Re-take the Python extensions for QtCreator project evaluation.

2019

2018