Basic Requirements Help

From Qt Wiki
Jump to: navigation, search

This article shows how to install the compiler and all the other basic requirements for application development with Qt. Just choose your host platform from the list.

Linux

Check out Qt for Linux/X11 to see if the official documentation has more or more recent information.

CentOS

sudo yum groupinstall "C Development Tools and Libraries"
sudo yum install mesa-libGL-devel

Debian

sudo apt-get install build-essential libgl1-mesa-dev

Fedora

sudo yum groupinstall "C Development Tools and Libraries"
sudo yum install mesa-libGL-devel

openSUSE

sudo zypper install -t pattern devel_basis

RHEL

sudo yum groupinstall "C Development Tools and Libraries"
sudo yum install mesa-libGL-devel

Ubuntu

sudo apt-get install build-essential libgl1-mesa-dev

Windows

  • Go to https://www.visualstudio.com/ and download Visual Studio 2015 Community
  • Run the installer and choose Custom installation
  • Select at least the following features:
    • Programming Languages / Visual C++ / Common Tools for Visual C++ 2015
    • Windows ad Web Development / Universal Windows App Development Tools / Tools (1.2) and Windows 10 SDK
  • After the installation has completed go to Start / Settings / System / Apps & features. Select Microsoft Software Development Kit - Windows 10.(...). Run Modify, then Change and add the feature Debugging Tools for Windows to your installation.