Building Applications for Symbian1 with Qt SDK 1.1

From Qt Wiki
Jump to: navigation, search
IMPORTANT: The content of this page is outdated. Reason: The Symbian platform is no longer supported.
If you have checked or updated this page and found the content to be suitable, please remove this notice.
This article may require cleanup to meet the Qt Wiki's quality standards. Reason: Auto-imported from ExpressionEngine.
Please improve this article if you can. Remove the {{cleanup}} tag and add this page to Updated pages list after it's clean.


English Български

Building Applications for Symbian^1 with Qt SDK 1.1

Description

Due to a bug at Qt SDK 1.1 qmake generates pkg files which does not include support for Symbian^1 (Symbian S60 5th Edition). As a result a compatibility warning is displayed during installation of the sis file of the application on Symbian^1 devices and application cannot be published for them in Nokia Ovi Store.

Workaround

The bug is still not resolved but there is a workaround. To fix it go to 1Qt473\mkspecs\features\symbian\default_post.prf and replace the following code:

# Supports Symbian^3 and Symbian^4 by default and also S60 3.1, 3.2, and 5.0 if built against any of those.
platform_product_id = S60ProductID
platform_product_id = $$addLanguageDependentPkgItem(platform_product_id)
pkg_platform_dependencies =  "; Default HW/platform dependencies"  "[0x20022E6D],0,0,0,{$$platform_product_id}"  "[0x20032DE7],0,0,0,{$$platform_product_id}"
contains(S60_VERSION, 3.1)|contains(S60_VERSION, 3.2)|contains(S60_VERSION, 5.0) {
 pkg_platform_dependencies +=  "[0x102032BE],0,0,0,{$$platform_product_id}"  "[0x102752AE],0,0,0,{$$platform_product_id}"  "[0x1028315F],0,0,0,{$$platform_product_id}"
}

with

# Supports Symbian^1, Symbian^3 and Symbian^4
platform_product_id = S60ProductID
platform_product_id = $$addLanguageDependentPkgItem(platform_product_id)
pkg_platform_dependencies =  "; Default HW/platform dependencies"  "; Symbian^1 (aka S60 5th Edition) "  "[0x1028315F],0,0,0,{$$platform_product_id}"  "; Symbian^3"  "[0x20022E6D],0,0,0,{$$platform_product_id}"  "; Symbian^4"  "[0x20032DE7],0,0,0,{$$platform_product_id}"

The modified code will allow you to build applications compatible to Symbian^1 (Symbian S60 5th Edition), Symbian^3 and Symbian^4.

See also

S60_VERSION and SYMBIAN_VERSION qmake variables are Unknown in Symbian^1 builds