Building Qt for Linux/ja

From Qt Wiki
Jump to: navigation, search
This article may require cleanup to meet the Qt Wiki's quality standards. Reason: Auto-imported from ExpressionEngine.
Please improve this article if you can. Remove the {{cleanup}} tag and add this page to Updated pages list after it's clean.
English Português Русский Spanish 日本語

Linux での Qt のビルド

Qt はたくさんのモジュール、configure のオプション、追加機能を持つ、とても大きなフレームワークです。ソースからのビルドに直面したとき、必要な依存関係をどうやって解決するか、ビルドに必要な機能を見極めようとするのはチャレンジでしょう!

"standard minimum configuration"(標準的な最小限の設定) として見なすことの出来る Linux の機能は: ZLib, JPEG, TIFF, MNG, PNG, OpenGL, GStreamer, ALSA, FreeType, FontConfig, CUPS, D-Bus, X*, OpenSSL, そして SQLite になるでしょう。

以下の表は Qt 4.5 から2010年12月時点の trunk の全てのバージョンが依存するパッケージ名の包括的なリストになります。Ubuntu のパッケージ名だけを示していますが、その他のディストリビューションのパッケージ名も追加してください。

「モジュール」の列がその機能で必要な最低レベルのモジュールを示しています(例えば、QtCore がその機能を使っていた場合、QtGui ではそのモジュールをリストに載せていません)。互いに独立な複数のモジュールに依存している場合はそれぞれのモジュールを記載しています。

依存機能 モジュール Configure のオプション Qt/X11? Qt/Embedded? Qt 4.5 Qt 4.6 Qt 4.7 Qt 4.8 (trunk)
ZLib QtCore system]‑zlib
JPEG QtCore system]‑libjpeg
TIFF QtCore system]‑libtiff
MNG QtCore system]‑libmng
PNG QtCore system]‑libpng
OpenGL QtOpenGL ‑opengl
OpenGL ES 1 QtOpenGL ‑opengl es1 [1]
OpenGL ES 1 CL QtOpenGL ‑opengl es1cl [2]
OpenGL ES 2 QtOpenGL ‑opengl es2 [3]
EGL QtOpenGL 1cl|2] [4]
OpenVG QtOpenVG ‑openvg
ShivaVG QtOpenVG ‑openvg
DirectFB QtGui plugin]‑gfx‑directfb
GStreamer[5] Phonon ‑phonon
PulseAudio Phonon ‑phonon‑backend
ALSA QtMultimedia ‑multimedia
NAS Sound QtGui ‑system‑nas‑sound
FreeType QtGui ‑freetype
FontConfig QtGui ‑fontconfig
tslib QtGui plugin]‑mouse‑tslib
Cups QtGui ‑cups
D‑Bus QtDBus ‑dbus[‑linked]
ICD QtNetwork ‑icd
GLib QtCore ‑glib
GTK QtGui ‑gtkstyle
X11 QtGui none
XShape QtGui ‑xshape
XCursor QtGui ‑xcursor
XFixes QtGui ‑xfixes
XRandr QtGui ‑xrandr
XRender QtGui, QtWebKit ‑xrender
XVideo Phonon, QtMultimedia ‑xvideo
Xinerama QtGui ‑xinerama
XInput QtGui ‑xinput
Session management QtGui ‑sm
OpenSSL QtNetwork, QtWebKit ‑openssl[‑linked]
Interbase QtSql plugin]‑sql‑ibase
MySQL QtSql plugin]‑sql‑mysql
ODBC QtSql plugin]‑sql‑odbc
PostgreSQL QtSql plugin]‑sql‑psql
SQLite 2 QtSql plugin]‑sql‑sqlite2
SQLite 3 QtSql plugin]‑sql‑sqlite
TDS QtSql plugin]‑sql‑tds
依存機能 Ubuntu Lucid(10.04) Ubuntu Maverick(10.10)
ZLib zlib1g‑dev zlib1g‑dev
JPEG libjpeg62‑dev libjpeg62‑dev
TIFF libtiff4‑dev libtiff4‑dev
MNG libmng‑dev libmng‑dev
PNG libpng12‑dev libpng12‑dev
OpenGL mesa‑common‑dev, libglu1‑mesa‑dev mesa‑common‑dev, libglu1‑mesa‑dev
OpenGL ES 1 none libgles1‑mesa‑dev[6]
OpenGL ES 1 CL none libgles1‑mesa‑dev
OpenGL ES 2 none libgles2‑mesa‑dev
EGL none libgles2‑mesa‑dev or libegl1‑mesa‑dev
OpenVG none libopenvg1‑mesa‑dev
ShivaVG none none
DirectFB libdirectfb‑dev libdirectfb‑dev
GStreamer libgstreamer0.10‑dev, libgstreamer‑plugins‑base0.10‑dev libgstreamer0.10‑dev, libgstreamer‑plugins‑base0.10‑dev
PulseAudio libpulse‑dev libpulse‑dev
NAS Sound libaudio‑dev libaudio‑dev
ALSA libasound2‑dev libasound2‑dev
FreeType libfreetype6‑dev libfreetype6‑dev
FontConfig libfontconfig1‑dev libfontconfig1‑dev
tslib libts‑dev libts‑dev
Cups libcups2‑dev libcups2‑dev
D‑Bus libdbus‑1‑dev libdbus‑1‑dev
ICD none none
GLib libglib2.0‑dev libglib2.0‑dev
GTK libgtk2.0‑dev libgtk2.0‑dev
X11 libx11‑dev, libxext‑dev libx11‑dev, libxext‑dev
XCursor libxcursor‑dev libxcursor‑dev
XFixes libxfixes‑dev libxfixes‑dev
XRandr libxrandr‑dev libxrandr‑dev
XRender libxrender‑dev libxrender‑dev
XVideo libxv‑dev libxv‑dev
Xinerama libxinerama‑dev libxinerama‑dev
XInput libxi‑dev libxi‑dev
Session management libsm‑dev libsm‑dev
OpenSSL libssl‑dev libssl‑dev
Interbase firebird2.1‑dev firebird2.5‑dev or firebird2.1‑dev
MySQL libmysqlclient‑dev libmysqlclient‑dev
ODBC unixodbc‑dev or libiodbc2‑dev[7] unixodbc‑dev or libiodbc2‑dev[8]
PostgreSQL libpq‑dev libpq‑dev
SQLite 2 libsqlite0‑dev libsqlite0‑dev
SQLite 3 libsqlite3‑dev libsqlite3‑dev
TDS freetds‑dev[9] freetds‑dev[10]
  1. サポートされていますが、Qt 4.5 でのビルド方法を見つけることが出来ませんでした。
  2. サポートされていますが、Qt 4.5 でのビルド方法を見つけることが出来ませんでした。
  3. サポートされていますが、Qt 4.5 でのビルド方法を見つけることが出来ませんでした。
  4. Qt for Embedded Linux のビルド時に、"configure" に ‑DMESA_EGL_NO_X11_HEADERS オプションを付ける必要があります。 .qmake.cache を使っても可能かもしれません。
  5. "configure" に "$(pkg‑config gstreamer‑interfaces‑0.10 gstreamer‑video‑0.10 gstreamer‑base‑0.10 ‑‑cflags‑only‑I)" オプションが必要です。
  6. 別途 libGLES_CM.so が必要となります。
  7. Qt 4.6 から unixodbc ではなく libiodbc2 がサポートされています。
  8. Qt 4.6 から unixodbc ではなく libiodbc2 がサポートされています。
  9. パッケージのインストール後に "ln ‑s libfbclient.so /usr/lib/libgds.so" の実行が必要です。
  10. パッケージのインストール後に "ln ‑s libfbclient.so /usr/lib/libgds.so" の実行が必要です。