Install Eclipse on Linux

From Qt Wiki
Jump to: navigation, search

En Ar Bg De El Es Fa Fi Fr Hi Hu It Ja Kn Ko Ms Nl Pl Pt Ru Sq Th Tr Uk Zh

  1. Install Eclipse 3.3.2 or higher
  2. Install Eclipse C/C++ CDT Plugin 4.0 or higher
  3. Download the Qt Eclipse Integration package corresponding to your Linux distribution
  4. Find your eclipse/plugins folder

If you installed Eclipse to e.g. /usr/local in step (1.), you will find the directory /usr/local/eclipse/plugins there. If you used the package management system of your Linux distribution to install Eclipse, this directory might possibly be /usr/lib/eclipse/plugins.

5. Unpack the package

Go to the location where you found the eclipse/plugins directory (i.e. /usr/local or /usr/lib in the examples in step (4.) ) and untar the package, e.g.

cd /usr/local
tar xzf ~/Downloads/qt-eclipse-integration-linux.x86-<version>.tar.gz

You might need to be the root user to do that.

6. Start Eclipse with a clean configuration

It is highly recommended by us to start Eclipse once from the command line with

eclipse -clean

after you unpacked the Qt Eclipse Integration plugins and feature.

This will not change anything in your workspace but will clear Eclipse's caches.

Uninstallation Instructions for Linux Systems

  1. Remove the installed plugins and feature

Go to the location where you installed the Qt Eclipse Integration package, e.g. /usr/local/eclipse or /usr/lib/eclipse, and remove all files/directories in plugins/ and features/ that start with com.trolltech.qtcpp

cd /usr/local/eclipse
rm -r plugins/com.trolltech.qtcpp*
rm -r features/com.trolltech.qtcpp*

2. Restart Eclipse with a clean configuration

It is highly recommended by us to start Eclipse once from the command line with

eclipse -clean

after you removed the Qt Eclipse Integration plugins and feature.

This will not change anything in your workspace but will clear Eclipse's caches.

Upgrading Instructions for Linux Systems

If you want to upgrade your Qt Eclipse Integration installation we highly recommend to first uninstall the older version:

1. Remove the older installed plugins and feature

Like described in step (1.) of the 'Uninstallation Instructions'.

2. Install the newer Qt Eclipse Integration

Like described in 'Installation Instructions'.

3. Restart Eclipse with a clean configuration