Talk:Native Build of Qt5 on a Raspberry Pi

From Qt Wiki
Jump to: navigation, search

Problem with qtbase.git during init-repository

How recently has init-repository worked?

I've tried but failed several times to git qtbase. I haven't had problems with others from the repository. The following is an excerpt during ./init-repository:

+ git clone --branch 5.5 git:// qtbase Cloning into 'qtbase'... fatal: The remote end hung up unexpectedly git clone --branch 5.5 git:// qtbase exited with status 32768 at ./init-repository line 221

Is there a workaround for this?

It still works, but there are some sporadic issues with the git server. Subscribe to the Interest mailing list and ask for details there. This Talk Page is for discussing the Wiki page itself. --JKSH (talk) 03:42, 12 April 2015 (UTC)

Problem wih the prefix set during the configure


First of all, I have to say that everything worked almost perfectly.

I ran the whole tutorial, it configured, build and install successfully.

But ...

During configure, we are told to use the following prefix: -prefix /usr/local/qt5

That's what I did but it seems that the prefix is finally related to the Qt's version being built, and in my case, the real prefix is /usr/local/Qt-5.6.0

I had to update LD_LIBRARY_PATH and PATH variables (and source my bashrc again) to use the real Qt's prefix in order to be able to have the expected output using the which command.

I tried to build and execute the cube example as told in the tutorial. Build is OK but I wasn't able to run the cube example, here is the error I had: Unable to query physical screen size, defaulting to 100 dpi. To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).

I first thought it was because I tried to run the example from the console (after being loged via ssh from my macbook to my pi), but I have the same error messages when I try to run the example from raspbian desktop (after being loged via vnc).

I wonder a few things, perhaps someone could help :

  • Is the error message related to the prefix change ?
  • Do I have to expect any side effects due to the prefix change ?
  • What values should I use to set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT ?
  • How do I set those values ?
  • Is there any other values to be set ?

Thanks for your answers.

Hi Ekaw, you'll have much better luck finding help if you post in People don't really notice posts in a Wiki talk page. --JKSH (talk) 14:06, 31 January 2016 (UTC)

stopping make process : xcb/xinerama.h no such file or directory

my make process stopped and the error was that the xcb/xinerama.h was missing . in order to solve this i had also to install libxcb-xinerama0-dev , so , in the first part , when there are many libraries instaled , this oane should also been included as sudo apt-get install libxcb-xinerama0-dev

== Update 17 July 2018: Installing the libraries I get: Package gstreamer0.10-plugins-bad is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it:

 gstreamer0.10-plugins-ugly gstreamer0.10-plugins-good gstreamer0.10-plugins-base