Qt Creator ManualTests ProjectsAndCode

From Qt Wiki
Jump to: navigation, search


Project Management
Test Result Annotation
Open a couple of Tutorials from the Welcome page and validate that they show up correctly.
Check parsing of qbs projects:
  1. Prepare sources of Qt Creator (see below)
  2. In "Help" -> "About Plugins…", verify that QbsProjectManager is enabled.
  3. Select "File"-> "Open File or Project…" from Creator's menu and open qtcreator.qbs from Qt Creator's sources.
  4. Select a suitable kit and click "Configure Project".
  5. Wait until parsing finished.
  6. Check that the project is completely indexed, e.g. by searching for some of Qt's Classes using the Locator.
Adding a build configuration:
  1. Open a project.
  2. Go to "Projects" mode.
  3. Add a new build configuration.
  4. The project can be built successfully with this build configuration.
Adding a run configuration:
  1. Open a project.
  2. Go to "Projects" mode.
  3. Add a new run configuration.
  4. The project can be run successfully with this run configuration.
Importing build of known kit:
  1. Build a project in Qt Creator.
  2. Close the project.
  3. Delete the file *.user from the project's directory.
  4. Open the project in Creator again.
  5. Import the build from step 1.

Validate that Creator uses the same kit as in step 1. A new kit must not be created.

Importing build of unknown kit:
  1. Build a project in Qt Creator.
  2. Close Creator.
  3. Delete the file *.user from the project's directory.
  4. Start Creator with empty settings, e.g. using the command line switch "-tcs". Do not have a Qt version in your PATH variable.
  5. Open the same project again.
  6. Import the build from step 1.
    Validate that Creator creates a new kit with the Qt version and toolchain used in step 1. It contains an appropriate debugger and can be used for building, running, debugging.
Removing kits:
  1. Have a couple of kits set up in Creator.
  2. Open a project and configure it with some kits.
  3. Go to "Tools" -> "Options" -> "Kits" -> "Kits".
  4. Remove a kit.
  5. Click "Apply".
  6. Remove another kit.
  7. Click "OK"

Validate that the project is still usable with the remaining kits and nothing undesired happens in the process.

Opening a project from Welcome screen:
  1. Close all open projects.
  2. Go to "Welcome" mode.
  3. Open a previously opened project by clicking its name in the Welcome screen.
automated
CMake project management:
  1. Have CMake installed.
  2. Checkout SpeedCrunch's source repository from https://bitbucket.org/heldercorreia/speedcrunch.git .
  3. Have a Kit using Qt 5.2 or later configured in Creator.
  4. Select "File" -> "Open File or Project…" from Creator's menu and open src/CMakeLists.txt.
  5. Select a Kit and click "Configure Project".
  6. Wait until parsing finished.
  7. Check that the project is completely indexed, e.g. by expanding items of the tree structure in the "Class View".
semi-automated
Creator can build and run the project from the previous test. automated
External changes:
  1. Open a file in Creator.
  2. Edit this file outside Creator, e.g. using some text editor.
  3. Go back to the file in Creator. Creator must report that the file was changed.
automated
Deleted files:
  1. Open a file in Creator.
  2. Delete this file outside Creator, e.g. using some file manager.
  3. Go back to the file in Creator. Creator must report that the file was deleted.
automated
Windows: Foreign character sets:
  1. Add a user whose name contains non-latin characters (Віталій , ‏ناصر , 右京) using Windows Control Panel.
  2. Login to this user account and run Creator.
  3. Create a session and activate this session. No warnings or error messages should appear.
Try to make Creator crash, be evil. ;-)
C++ Support
Test

When running the following tests, please sure that the ClangCodeModel plugin is enabled, which is the default.

Result Annotation
Open the project tests/manual/cplusplus-tools/cplusplus-tools.pro from Creator's sources and perform the following tasks:
Variable declarations:
  1. Move the cursor to the usage of a variable.
  2. Press F2 or select from the menu: Tools-> C++ -> Follow Symbol under Cursor

Creator will show you the declaration of the variable.

automated
Function definitions:
  1. Move the cursor to a function call.
  2. Press F2 or select from the menu: Tools-> C++ -> Follow Symbol under Cursor

Creator will show you the definition of the function.

automated
Definition/declaration:
  1. Move the cursor to a function declaration
  2. Press Shift+F2 or select from menu: Tools-> C++ -> Switch Between Method Declaration/Definition

Creator should show the definition of this function

  1. Press Shift+F2 or select from menu: Tools-> C++ -> Switch Between Method Declaration/Definition again

Creator should show the declaration of the function again.

automated
Switching between sources and headers:
  1. Open a source or header file of a source/header couple (same base name)
  2. Press F4 or select from menu: Tools-> C++ -> Switch Header/Source

Creator should show the respective other file (header/source).

Finding usages:
  1. Open a header or source file
  2. Move cursor to the usage of a variable or function call
  3. Press Ctrl+Shift+U or select from menu: Tools-> C++ -> Find Usages

A search result view should appear at the bottom indicating files containing usages of this variable or function. When expanding the tree view-like structures, the respective lines can be seen. Double clicking on them should direct you to this file and line

Renaming usages:
  1. Move cursor to a variable or function call
  2. Press Ctrl+Shift+R or select from menu Tools-> C++ -> Rename Symbol Under Cursor

You should be able to enter another name changing every occurrence of this variable or function.
Note: When changing variable "a" to "b", other variables like "a1" must not be changed!

automated
When entering the first few letters of a variable or function (or: includes, keywords, function arguments, snippets, etc), Creator should automatically show possible completions. You might have to hit Ctrl+Space.
Configure Qt documentation in "Tools" -> "Options..." -> "Help" -> "Documentation".

After this, when hovering the mouse over some variable or function call, a tooltip should appear telling you the type of this element. In case it's a Qt object (like QString, QWidget, …), you should see a picture of the F1 button in the top right corner of the tooltip, indicating that you can easily switch to the Qt documentation of this class or method by pressing F1. Pressing F1 will open the related page.

Try code folding. Fold and unfold classes and functions. Does everything work as expected?
Try triggering Quick Fixes at different code lines by pressing Alt+Enter. Does Creator offer Quick Fixes and does it change the code correctly when you use one of them?

Preparing sources of Qt and Qt Creator

This can be used for all following tests after it was done once.
Simply download sources of Qt (tar.xz/zip) and Qt Creator (tar.gz/zip) and extract them. You have to build Qt outside of qtcreator. Otherwise qtcreator won’t be able to parse the Qt sources.